0 beğenilme 0 beğenilmeme
48 kez görüntülendi
STMicroelectronics kategorisinde (3,920 puan) tarafından

Eclipse ile derlediğim projeyi yüklemek istediğimde aşağıdaki hata çıktısını alıyorum.
Driver'lar güncel. ST-link v1 kullanıyorum.

xPack OpenOCD, 64-bit Open On-Chip Debugger 0.10.0+dev (2019-07-17-11:28)
Licensed under GNU GPL v2
For bug reports, read
    http://openocd.org/doc/doxygen/bugs.html
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
srst_only separate srst_nogate srst_open_drain connect_deassert_srst

Started by GNU MCU Eclipse
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : clock speed 2000 kHz
Error: libusb_open() failed with LIBUSB_ERROR_NOT_SUPPORTED
Error: open failed

1 cevap

1 beğenilme 0 beğenilmeme
(2,620 puan) tarafından
tarafından seçilmiş
 
En İyi Cevap

STLinklerin eski driverlarının arası openocd ile pek iyi değildi. Belki HAL kütüphanelerinden sonra değişmiştir ama deneyebiliceklerin şunlar;

1- Zadig ile USB driverı WinUSB yapmak
2- STlink FW sini JLink olarak değiştirmek bu resmi olarak desteği olan bir proje

V1 yine çalışmayabilir ama v2 her türlü yürüyordu.

...